Zyxel GS1920-24V2 network switch Managed Gigabit Ethernet (10/100/1000) Black
Zyxel GS1920-24V2, Managed, Gigabit Ethernet (10/100/1000), Rack mounting
MSRP
$336.30
Public MSRP in CAD. Your quoted price comes from an account manager.
Get your price from a Dataworld account manager.
View Your Quote RequestTalk to Us(514) 738-6350
- Canadian-owned since 1979
- Authorized reseller of every brand we carry
- Public MSRP
- English and French
- For Canadian businesses
Overview
Zyxel GS1920-24V2. Switch type: Managed. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 24. MAC address table: 16000 entries, Switching capacity: 56 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE.... Rack mounting
Key Features
- NebulaFlex™ gives you the flexibility to switch between standalone and our license-free Nebula cloud management
- Nebula cloud management allows easy deployment real-time configurations and effortless access to all your cloud devices anytime
- Using user-friendly web-based GUI to manage and set up the switch without learning complex CLI
- Smart fan and fanless designs offer silent operations in your office
- Check real-time status intuitively by cloud and PoE LED indicators
Explore More
Specifications
- Switch type
- Managed
- Quality of Service (QoS) support
- Yes
- ARP inspection
- Yes
- System event log
- Yes
- MIB support
- RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
- Basic switching RJ-45 Ethernet ports quantity
- 24
- Basic switching RJ-45 Ethernet ports type
- Gigabit Ethernet (10/100/1000)
- Combo SFP ports quantity
- 4
- Fiber optic connector
- SFP
- Networking standards
- IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
- 10G support
- No
- Copper ethernet cabling technology
- 100BASE-TX, 1000BASE-T
- Flow control support
- Yes
- Rate limiting
- Yes
- Spanning tree protocol
- Yes
- VLAN support
- Yes
- Virtual LAN features
- Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
- Fiber ethernet cabling technology
- 1000BASE-X
- Switching capacity
- 56 Gbit/s
- Forwarding rate
- 42 Mpps
- MAC address table
- 16000 entries
- Packet buffer memory
- 1.5 MB
- DHCP features
- DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client
- Access Control List (ACL)
- Yes
- IGMP snooping
- Yes
- Security algorithms
- 802.1x RADIUS, SNMP, SNMPv3
- MAC address filtering
- Yes
- IP-MAC-Port binding
- Yes
- Authentication
- Guest VLAN, Port-based authentication
- Password protection
- Yes
- Authentication type
- IEEE 802.1x, RADIUS
- CPU defense
- Yes
- Queue scheduling algorithms
- SPQ, WFQ, Weighted Round Robin (WRR)
- Multicast support
- Yes
- Rack mounting
- Yes
- Product colour
- Black
- LED indicators
- Yes
- Safety
- LVD, BSMI
- Electromagnetic compatibility
- FCC 15 A, CE A, BSMI EMC
- Internal memory
- 256 MB
- Flash memory
- 32 MB
- Noise level
- 0 dB
- Mean time between failures (MTBF)
- 911301 h
- AC input voltage
- 100 - 240 V
- AC input frequency
- 50 - 60 Hz
- Power consumption (max)
- 22.5 W
- Power over Ethernet (PoE)
- No
- Operating temperature (T-T)
- 0 - 50 °C
- Storage temperature (T-T)
- -40 - 70 °C
- Operating relative humidity (H-H)
- 10 - 95%
- Storage relative humidity (H-H)
- 10 - 95%
- Heat dissipation
- 76.73 BTU/h
- Width
- 441 mm
- Depth
- 131 mm
- Height
- 44 mm
- Weight
- 2.1 kg
- Cables included
- AC
- Rack mount kit
- Yes
- Package width
- 558 mm
- Package depth
- 214 mm
- Package height
- 79 mm
- Package weight
- 2.91 kg
- Certification
- RoHS
- Harmonized System (HS) code
- 85176990
Buying from Dataworld
- A competitive CAD quote from a Dataworld account manager.
- Montreal-based, serving Canadian businesses in English and French.




