Zyxel
Zyxel GS1900-8 network switch Managed Gigabit Ethernet (10/100/1000) Black
Zyxel GS1900-8, Managed, Gigabit Ethernet (10/100/1000)
Part NumberGS1900-8
UPC760559120986
MSRP
$107.89
Public MSRP in CAD. Your quoted price comes from an account manager.
Available to Order
Quantity
Get your price from a Dataworld account manager.
View Your Quote RequestPaste your parts list or upload a CSV
Talk to Us(514) 738-6350
- Canadian-owned since 1979
- Authorized reseller of every brand we carry
- Public MSRP
- English and French
- For Canadian businesses
Overview
Zyxel GS1900-8. Switch type: Managed. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 8. Networking standards: IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Explore More
Specifications
- Switch type
- Managed
- Quality of Service (QoS) support
- Yes
- MIB support
- RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493
- Basic switching RJ-45 Ethernet ports quantity
- 8
- Basic switching RJ-45 Ethernet ports type
- Gigabit Ethernet (10/100/1000)
- Gigabit Ethernet (copper) ports quantity
- 8
- Networking standards
- IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
- 10G support
- No
- Copper ethernet cabling technology
- 1000BASE-T, 100BASE-TX, 10BASE-T
- Flow control support
- Yes
- Broadcast storm control
- Yes
- Rate limiting
- Yes
- Security algorithms
- 802.1x RADIUS
- MAC address filtering
- Yes
- SSH/SSL support
- Yes
- Management protocols
- SNMP v1,v2,v3, RMON (1,2,3,9)
- Product colour
- Black
- Safety
- LVD EN60950-1, BSMI CNS14336-1
- Power over Ethernet (PoE)
- No
- Certification
- CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438
Buying from Dataworld
- A competitive CAD quote from a Dataworld account manager.
- Montreal-based, serving Canadian businesses in English and French.


