Skip to main content
Dataworld, authorized IT and AV reseller in Canada
Menu

Shop by Department

Language
TP-Link JetStream 16-Port Gigabit Smart Switch with 8-Port PoE+ product photo
TP-Link

TP-Link JetStream 16-Port Gigabit Smart Switch with 8-Port PoE+

TP-Link JetStream 16-Port Gigabit Smart Switch with 8-Port PoE+, L2/L3/L4, Gigabit Ethernet (10/100/1000), Power over Ethernet (PoE)

Part NumberSG2016P
UPC0840030709494

MSRP

Price on Request

Available to Order
Quantity

Get your price from a Dataworld account manager.

View Your Quote Request

Overview

TP-Link JetStream 16-Port Gigabit Smart Switch with 8-Port PoE+. Switch layer: L2/L3/L4. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 16. MAC address table: 8000 entries, Switching capacity: 16 Gbit/s. Networking standards: IEEE 802.11w, IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1x, IEEE 802.3ab, IEEE.... DC input voltage: 53.5 V. Power connector: DC-in jack. Power over Ethernet (PoE)

Key Features

  • 120 W PoE Budget: 8× 802.3at/af-compliant PoE+ ports with a total power supply of 120 W*
  • Full Gigabit Ports: 8× gigabit PoE+ ports and 8× gigabit non-PoE ports provide high-speed connections
  • Integrated into Omada SDN: Zero-Touch Provisioning**, Centralized Cloud Management, and Intelligent Monitoring
  • Centralized Management: Cloud access and Omada app for ultra convenience and easy management
  • Robust Security Strategies: IP-MAC-Port Binding, ACL, Port Security, DoS Defend, Storm control, DHCP Snooping, 802.1X, Radius Authentication, and more
  • Optimize Voice and Video Applications: L2/L3/L4 QoS and IGMP snooping

Explore More

Specifications

Switch layer
L2/L3/L4
Quality of Service (QoS) support
Yes
Web-based management
Yes
Cloud-managed
Yes
ARP inspection
Yes
Configuring Location Settings (CLI)
Yes
System event log
Yes
MIB support
RFC1213, RFC1493, RFC2674, RFC2620, RFC2618, RFC2925, RFC1757

Buying from Dataworld

  • A competitive CAD quote from a Dataworld account manager.
  • Montreal-based, serving Canadian businesses in English and French.

MSRP

Price on Request