Skip to main content
Dataworld, authorized IT and AV reseller in Canada
Menu

Shop by Department

Language
TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+ product photo
TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+ product photo
TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+ product photo
TP-Link

TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+

TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+, Managed, L2/L2+, Gigabit Ethernet (10/100/1000), Power over Ethernet (PoE), Rack mounting, 1U

Part NumberSG2210MP
UPC0845973088675

MSRP

$259.99

Public MSRP in CAD. Your quoted price comes from an account manager.

In Stock
Quantity

Get your price from a Dataworld account manager.

View Your Quote Request

Overview

TP-Link JetStream 10-Port Gigabit Smart PoE Switch with 8-Port PoE+. Switch type: Managed, Switch layer: L2/L2+. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 8. MAC address table: 8000 entries, Switching capacity: 20 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE.... Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Key Features

  • 150 W PoE Budget: 8× 802.3at/af-compliant PoE+ ports with a total power supply of 150 W*
  • Full Gigabit Ports: 8× gigabit PoE+ ports and 2× gigabit SFP Slots provide high-speed connections
  • Integrated into Omada SDN: Zero-Touch Provisioning (ZTP)**, Centralized Cloud Management, and Intelligent Monitoring
  • Centralized Management: Cloud access and Omada app for ultra convenience and easy management
  • Robust Security Strategies: IP-MAC-Port Binding, ACL, Port Security, DoS Defend, Storm Control, DHCP Snooping, 802.1X, Radius Authentication, and more
  • Optimize Voice and Video Applications: L2/L3/L4 QoS and IGMP snooping

Explore More

Specifications

Switch type
Managed
Switch layer
L2/L2+
Quality of Service (QoS) support
Yes
Web-based management
Yes
Cloud-managed
Yes
ARP inspection
Yes
Configuring Location Settings (CLI)
Yes
System event log
Yes
MIB support
RFC2925, RFC2618, RFC2620, RFC2021, RFC2819, RFC2674, RFC1213, RFC2233, RFC1643, RFC1493

Buying from Dataworld

  • A competitive CAD quote from a Dataworld account manager.
  • Montreal-based, serving Canadian businesses in English and French.

MSRP

$259.99