Skip to main content
Dataworld, authorized IT and AV reseller in Canada
Menu

Shop by Department

Language
TP-Link Omada 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++ product photo
TP-Link

TP-Link Omada 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++

TP-Link Omada 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++, Managed, L2+, 2.5G Ethernet (100/1000/2500), Power over Ethernet (PoE), Rack mounting, 1U

Part NumberSG3428XPP-M2
UPC0840030709739

MSRP

$1,099.99

Public MSRP in CAD. Your quoted price comes from an account manager.

In Stock
Quantity

Get your price from a Dataworld account manager.

View Your Quote Request

Overview

TP-Link Omada 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++. Switch type: Managed, Switch layer: L2+. Basic switching RJ-45 Ethernet ports type: 2.5G Ethernet (100/1000/2500), Basic switching RJ-45 Ethernet ports quantity: 24, Console port: RJ-45/Micro-USB. Full duplex. MAC address table: 32000 entries, Switching capacity: 200 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE.... Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Key Features

  • 8× 2.5G PoE++ ports (up to 60 W PoE out per port)**
  • 16× 2.5G PoE+ ports (up to 30 W PoE out per port)
  • 4× 10G SFP+ slots
  • 500 W total PoE budget*
  • Centralized cloud management via the web or the Omada app†
  • Standalone management via web, CLI, SNMP, and RMON
  • Static Routing helps route internal traffic for higher efficiency
  • VLAN, ACL, QoS, IGMP Snooping, OAM, and DDM
  • ERPS supports rapid protection and recovery in a ring topology

Explore More

Specifications

Switch type
Managed
Switch layer
L2+
Quality of Service (QoS) support
Yes
Web-based management
Yes
Cloud-managed
Yes
ARP inspection
Yes
Configuring Location Settings (CLI)
Yes
System event log
Yes
MIB support
RFC1213, RFC2233, RFC1643, RFC1493, RFC2674, RFC2819, RFC2021, RFC2620, RFC2618, RFC2925

Buying from Dataworld

  • A competitive CAD quote from a Dataworld account manager.
  • Montreal-based, serving Canadian businesses in English and French.

MSRP

$1,099.99